TheSamba.com Forums
 
  View original topic: oil pressure light, not lighting up.
yukon Tue Jun 13, 2006 6:05 pm

howdy there folks
I have a 84 1.9 westy, 174000 miles. My oil pressure light has started to slowly come on , faint at first and slowly glowing brighter as the engine warms up. I haven't been driving it, working on it's other issues mostly. I switched to 20w50 after reading here in the forum, and some lifter noise did go away. Any ways yesterday the oil light didn't come on, then i noticed that it doesen't even light up when i first turn on the ignition. So i went through the manual and test the led for oil while in the circuit foil, didn't light up. SO i got a new led , still didn't light up . I tested the old led out of the foil and then it lights up. The other led's do light up in the foil circuit though. Is the problem in the circuit foil ? I haven't checked the actual oil pressure with a guage yet , but will soon. Any info would be great. Thanks.

tencentlife Wed Jun 14, 2006 1:30 pm

Check the resistor for the oil pressure LED in the circuit foil. It should have 470 Ohm across it. Also remove the wire at the pressure sensor on the engine and make sure that at rest the switch contact has continuity to ground. If those check out then test for continuity between contact #10 on the 14-point instrument cluster connector and the pressure sensor wire (or to ground if the sensor is OK and you reconnect the sensor wire).

Fix whichever of these things has a fault, and then see if you still have a dimly glowing light at hot idle. If so, test engine oil pressure hot with a remote gauge. Bentley says that your pressure switch is a 0.3 bar in the engine chapter, but in the wiring diagram it shows a 1.8bar switch. If it were a 1.8bar, the engine would have trouble keeping the light out at a hot idle. Find out what switch you have (some of them have the switching pressure embossed in the plastic of the switch body in very fine print).

yukon Fri Jun 16, 2006 7:09 pm

hey there tencent

Thanks for the info , i ended up hooking up a remote oil pressure gauge first just to be sure and i have 60 lbs. with the rpms wound up a bit and at idling i have about 6 to 7 lbs. THis is with the engine warm of course. Next i'll start looking into the rest of your suggestions. I think i'm just going to hook up a oil press guage for my own peace of mind . I saw a kit for one offered from one of the venders for alot of cash. I ended up going down to my local auto parts store and they got me lined out for about 25 dollors. Which was nice. Thanks again for the info



Powered by phpBB © 2001, 2005 phpBB Group