TheSamba.com Forums
 
  View original topic: Empi 34p3 carb.
samk47 Tue Jun 16, 2020 5:56 pm

I recently finished my trike, it`s a 61 transaxle, recently rebuilt standard 1600, Empi 34p3 carb. with manual choke, (carb. is new), points distributor. Nothing has been hot-rodded. It goes down the road nice and runs fine, but every time I start it I have to hold the throttle wide open til it starts. I replaced the needle & seat, with 2 washers on it, no difference. I added about 2/3 of a can of carb. cleaner to the gas tank, witch had about 5 gal. in it, no difference. I contacted the man who did the motor, ( he races sand rail vws) and he hadn`t ever heard of such trouble. So that`s why I am here, I am hoping some of you guys have some ideas for me. I can`t afford to have a mechanic fix it cause social sec. doesn`t go very far. I would sure appreciate any input you guys have, Thank you very much. samk47

wcfvw69 Tue Jun 16, 2020 7:47 pm

samk47 wrote: I recently finished my trike, it`s a 61 transaxle, recently rebuilt standard 1600, Empi 34p3 carb. with manual choke, (carb. is new), points distributor. Nothing has been hot-rodded. It goes down the road nice and runs fine, but every time I start it I have to hold the throttle wide open til it starts. I replaced the needle & seat, with 2 washers on it, no difference. I added about 2/3 of a can of carb. cleaner to the gas tank, witch had about 5 gal. in it, no difference. I contacted the man who did the motor, ( he races sand rail vws) and he hadn`t ever heard of such trouble. So that`s why I am here, I am hoping some of you guys have some ideas for me. I can`t afford to have a mechanic fix it cause social sec. doesn`t go very far. I would sure appreciate any input you guys have, Thank you very much. samk47

What kind of fuel pump are you running on the engine? Is it an electric fuel pump or the original style? Have you checked what kind of fuel pressure you're getting from it? 34-3 carbs like 3 psi plus or minus .5 psi. Many aftermarket fuel pumps can put out 5 psi and above. That high fuel pressure can overwhelm the valve under the float.

EMPI Chinese 34-3 carbs can be hit or miss in quality. Some say they work ok while most avoid them. I had a new one on a VW I purchased. I couldn't get it to work correctly at all. The tolerances in it where terrible. I installed a rebuilt/restored original German Solex 34-3 carb and my problems were resolved.

andk5591 Wed Jun 17, 2020 4:56 am

did you follow the set up procedure that comes with the carbs? VERY important. Very possible your choke is set wrong. You can go to vw-resource.com on how to set that. Also you should ALWAYS clean a new carb before installing it.

I have not had issues with the newer Empi carbs, but have had to set up more than one at the shop that an owner installed and didnt adjust first.

volkybus Wed Aug 12, 2020 9:11 pm

It seems like your carb is flooding...high fuel pressure would do that or a leaking float seal...Bill
Check both...good luck Bill. (VT)



Powered by phpBB © 2001, 2005 phpBB Group