Hello! Log in or Register   |  Help  |  Donate  |  Buy Shirts  See all banner ads | Advertise on TheSamba.com  
TheSamba.com
 
How do I take Speedometer out, apart?
Page: 1, 2, 3, 4, 5, 6  Next
Forum Index -> Beetle - 1958-1967 Share: Facebook Twitter
Reply to topic
Print View
Quick sort: Show newest posts on top | Show oldest posts on top View previous topic :: View next topic  
Author Message
64vdub
Samba Member


Joined: August 05, 2008
Posts: 612
Location: Sunny So. Cal
64vdub is offline 

PostPosted: Thu Nov 06, 2008 10:31 am    Post subject: How do I take Speedometer out, apart? Reply with quote

Okay, so my problem is that all of the sudden the needle on my speedometer will freeze while driving. If I tap on the lens it will start to move again properly for a while than freeze again. This just started yesterday If anybody has any solutions let me know. I checked to make sure cable was in good shape and tight, and it is. My other questions are: Is it easy to take speedometer out and take it apart? I did a search to find some directions with pics and only found one for a later model. I have an original 64' speedo in my 64'. Thanks in advance.
Back to top
View user's profile Send private message Gallery Classifieds Feedback
glutamodo Premium Member
The Android


Joined: July 13, 2004
Posts: 23263
Location: Douglas, WY
glutamodo is offline 

PostPosted: Thu Nov 06, 2008 12:00 pm    Post subject: Reply with quote

You probably found this thread:

http://www.thesamba.com/vw/forum/viewtopic.php?t=179776&start=10

And all of that applies to your earlier speedometer. The only differences is there is no gas gauge in it, and the "gels" are glued to the speedometer faceplate instead of contained in rubber holders.

I'll tell you what though, I have some time today so I'll do a similar series of photos of a 1964 speedometer that I have here.
Back to top
View user's profile Send private message Send e-mail Gallery Classifieds Feedback
Woreign
Samba Member


Joined: June 04, 2006
Posts: 2841
Location: Crestview FL
Woreign is offline 

PostPosted: Thu Nov 06, 2008 12:13 pm    Post subject: Reply with quote

It sounds like you might have some grease where it shouldn't be. I had grease from the speedometer cable leak into the speedometer bell housing one time. It caused the speedometer to stick until the magnetic force overcame the friction the grease was causing.

To open up the speedometer, you need to carefully pry up the chrome ring from the back with a small flat screw driver. You can then remove the ring and the glass from the front of the speedometer housing. Then remove the two screws from the back that hold the speedometer gears and face inside the housing. With the housing removed, you can carefully pick out/clean the old grease from the odometer gears and speedometer bell housing. Be VERY careful that you don't bend/break/unspring anything. I used spray brake cleaner to clean out the speedometer bell housing. Then I carefully applied white lithium grease to the odometer gears. Be sure to wipe away any extra! You don't want it getting back into the speedometer bell housing. It's no fun removing and opening up the speedometer a second time for the same problem (ask me how I know)...

Good luck!
Back to top
View user's profile Send private message Gallery Classifieds Feedback
64vdub
Samba Member


Joined: August 05, 2008
Posts: 612
Location: Sunny So. Cal
64vdub is offline 

PostPosted: Thu Nov 06, 2008 12:19 pm    Post subject: Reply with quote

Thanks a lot. I am in Southern California and we are finally having some cooler weather. I wonder if it is sticking because the grease is hardening due to the cold weather. With weeks straight of 100 degree temps the grease may have warmed up and ran into places it shouldn't be just like you said
Back to top
View user's profile Send private message Gallery Classifieds Feedback
glutamodo Premium Member
The Android


Joined: July 13, 2004
Posts: 23263
Location: Douglas, WY
glutamodo is offline 

PostPosted: Thu Nov 06, 2008 1:11 pm    Post subject: Reply with quote

There's not much grease in there. The factory grease I don't believe was white lithium. But that should be as good as any. Personally I might try a very light coat of moly grease, as I've found that works great on anything I've ever used it on.

I'll be posting a series of detailed captioned photos of taking the speedometer apart here in an hour or two.

-Andy
Back to top
View user's profile Send private message Send e-mail Gallery Classifieds Feedback
andk5591 Premium Member
Samba Member


Joined: August 29, 2005
Posts: 14040
Location: State College, PA
andk5591 is offline 

PostPosted: Thu Nov 06, 2008 1:29 pm    Post subject: Reply with quote

Something else - on the speedo mechanism itself (not the odometer gears), I have used light machine oil (3-n-1) with great success. Had a jumpy, noisy speedo - lubed it and 6000 miles later its still smooth.
_________________
D-Dubya Manx clone - 63 Short pan,1914.
Rosie 65 bug - My mostly stock daily driver.
Woodie 69 VW woodie (Hot VWs 7/12).
"John's car" 64 VW woodie - The first ever
Maxine 61 Cal-look bug - Cindy's daily driver.
Max - 73 standard Beetle hearse project
66 bug project - Real patina & Suby conversion
There's more, but not keeping them...
Back to top
View user's profile Send private message Send e-mail AIM Address Gallery Classifieds Feedback
glutamodo Premium Member
The Android


Joined: July 13, 2004
Posts: 23263
Location: Douglas, WY
glutamodo is offline 

PostPosted: Thu Nov 06, 2008 1:53 pm    Post subject: Reply with quote

Yeah, often times, you can lube it up for noise without dismantling. I usually use some Liquid Wrench Non-Flammable - just point the input shaft straight up, spray some and let it soak in.
Back to top
View user's profile Send private message Send e-mail Gallery Classifieds Feedback
HerrrKafer
Samba Member


Joined: June 02, 2004
Posts: 1474
Location: East Fishkill, NY
HerrrKafer is offline 

PostPosted: Thu Nov 06, 2008 1:58 pm    Post subject: Reply with quote

x2, see what a few drops of 3N1 does before you take it apart.

glutamodo wrote:
I'll tell you what though, I have some time today so I'll do a similar series of photos of a 1964 speedometer that I have here.
Hey, that would be swell. I'm actually just curious if the early speedometers also have the pre-spring set mark, as I've only had late speedos apart.
_________________
Evan H.

EverettB wrote:
In a perfect world, anyone running chromies would be shot.
Back to top
View user's profile Send private message Gallery Classifieds Feedback
glutamodo Premium Member
The Android


Joined: July 13, 2004
Posts: 23263
Location: Douglas, WY
glutamodo is offline 

PostPosted: Thu Nov 06, 2008 2:05 pm    Post subject: Reply with quote

HerrrKafer wrote:
]Hey, that would be swell. I'm actually just curious if the early speedometers also have the pretension set mark, as I've only had late speedos apart.


Nope, they do not. The one I'm working on was one I used for years and years in my Baja bug, which I'm not sure if it was accurate though as I never used stock tires with it, so it was always off regardless. But, I did take a picture of where its needle ended up when pulled up over the stop peg. (I'm about halfway through editing and captioning the photos)

-Andy
Back to top
View user's profile Send private message Send e-mail Gallery Classifieds Feedback
glutamodo Premium Member
The Android


Joined: July 13, 2004
Posts: 23263
Location: Douglas, WY
glutamodo is offline 

PostPosted: Thu Nov 06, 2008 5:53 pm    Post subject: Reply with quote

Okay, here it is!

Again, compare these photos with the late model ones found in this thread:

http://www.thesamba.com/vw/forum/viewtopic.php?t=179776&start=10

Okay, here's the candidate for dismantling - a speedometer that I used for many years and was running good when I swapped it out for a 1968 version. As mentioned above, I don't know if the calibration was right on the speedometer needle though, as I never ran tires that were stock height with this.

All but the last 2 photos here were edited down to 640 pixels wide. The site may resize these on your computer, so doing the "click on the photo to enlarge" thing might make them look better if they look poor to you.

1.Front:

Image may have been reduced in size. Click image to view fullscreen.


2. Rear - note the date stamp - 10/63. That would have originally been from Model Year 1964. I'm not sure what I did with the housing for the three warning lights at the bottom. It should be on there.

Image may have been reduced in size. Click image to view fullscreen.


3. I used the chisel bit on my Victorinox "Swisstool" to pry the cover off. I'd had this one apart before to change the miles and put on new gels. So it came off pretty quickly for me this time.

Image may have been reduced in size. Click image to view fullscreen.



4. I removed the two screws on the back, then I had to twist some on the inner assemby to get the metal sleeve for the high beam lights to disengage. Also, there was a rubber gasket that fell out, that was in between the cover and the housing.

Image may have been reduced in size. Click image to view fullscreen.


5. Here's the view of it on the insides" - note the sun-blasted "gels" (which saw many years of use since I put them in, those were made from Pendeflex folder tabs) and the metal sleeve for the high beam lights:

Image may have been reduced in size. Click image to view fullscreen.


6. Before you remove the needle, you need to have some kind of baseline to have when you reassemble it. Putting a cable on the speedometer and running it (reverse) in a drill that you know will have the same speed later on, and observing the speed is one way to get such a baseline. The other is to move the needle over then stop peg, set the speedometer up so that it's upright, and take a photo like this of the amount of spring pretension it has. The danger in doing this, is that the needles are often brittle and can break off when moving them over the stop peg.

Image may have been reduced in size. Click image to view fullscreen.


7. If all you want to do is unstick a sticking needle, you might just be able to do as mentioned, and try to spray some brake-kleen at the uppper bushing, which is identified here:

Image may have been reduced in size. Click image to view fullscreen.


8. Here's the needle removed, I just pulled straight up on the black center piece to pop it off. You can see the needle is two pieces here, the white needle snaps into a D-shaped hole on the black center piece, which has splines. The brass needle mount bushing, of course, is also splined:

Image may have been reduced in size. Click image to view fullscreen.


9. Resetting the Odometer. You have to pull the shaft that the odometer connecting gears ride on. If you are lucky like I was, you can pull it back just a little bit and not have all the gears fall off and scatter. Here's an overview photo:

Image may have been reduced in size. Click image to view fullscreen.


10. I pulled the shaft back just enough to get them loose. I could not adjust the very last number but that was OK. The other ones, I just twirled around with my finger (they freewheel with those gears disengaged) til they read zero. Then I lined the gears up all the same way, which you have to do or it wont go back together again:

Image may have been reduced in size. Click image to view fullscreen.


11. Once I got the gears lined up, I used my pliers to pop the shaft back into place.

Image may have been reduced in size. Click image to view fullscreen.



12. Here's the final result - 00004 miles:

Image may have been reduced in size. Click image to view fullscreen.


13. To dig in deeper: Next up is to get the faceplate off, you'll have to first remove that brass needle mount bushing. The brass needle mount bushing thing, is a press fit onto the drive shaft - so taking if off and remounting it might result in the splines being off from before, and not allowing the same calibration as previously. Keep that in mind before removing it.

To get it off - I first tried pulling on it with some pliers, but it didn't budge and I didn't want to dig into it hard with the pliers. So I got a smaller set of diagonal pliers, and put them under it, and used them to pry up on it, and it popped off.

Image may have been reduced in size. Click image to view fullscreen.


14. Here's a closeup of the press-fit side of the speedometer needle mount bushing:

Image may have been reduced in size. Click image to view fullscreen.


15. Here's a picture of the tension spring. I don't think I'd want to mess with that stake that holds the spring down.

Image may have been reduced in size. Click image to view fullscreen.


16. To separte the rest of this speedometer, there are some "twist tabs" that hold it together. You'll be doing the outer two next. You can see one of these in this next picture:

Image may have been reduced in size. Click image to view fullscreen.


16a. Here's a picture of one of these twist-tabs being straightened and pushed through:

Image may have been reduced in size. Click image to view fullscreen.


17. Once you have those tabs pushed though, you can separate the two parts of the speedometer inner assembly. The base of the speedometer needle is a large steel "cup" that fits over a magnet that is on the end of the input shaft that the speedometer cable attaches to. As the magnet spings, magnetic induction moves the "cup" and thus, the needle. The amount of pretension on the needle determines the calibration.

Anyway, you'll be taking the cup part off from over the magnet here. You'll be able to see the inner bushing that the cup/needle assembly rotates on. I do not believe this is lubricated, if anything I would polish it with a clean cloth to maybe some micro-fine steel wool.

Image may have been reduced in size. Click image to view fullscreen.


18. Here's another picture of the two halves, separated, plus pointing out the next item you'll have to remove, the piece that the bushing for the speedo cup/needle pin fits into:

Image may have been reduced in size. Click image to view fullscreen.


19. Next up, taking the input shaft/magnet out. There's a couple of things you'll have to do. Straightening these tabs is one of them:

Image may have been reduced in size. Click image to view fullscreen.


20. After the tabs are straight, you might have to use a screwdriver to help get that piece loose.

Image may have been reduced in size. Click image to view fullscreen.


21-24. I found that the plastic worm drive for the odometer would prevent removal of the input shaft/magnet. So I had to loosen it. To do that, I had to take off the brass bushing at one end. I used some needle nose pliers that had a "circle" around the cutter portion, which fit nicely over the brass bushing allowing a tight even grip, then I twisted on it and pulled up to remove:

Image may have been reduced in size. Click image to view fullscreen.

Image may have been reduced in size. Click image to view fullscreen.

Image may have been reduced in size. Click image to view fullscreen.

Image may have been reduced in size. Click image to view fullscreen.




25. Here's the input shaft/magnet removed. I cleaned the old grease off it. I'd probably polish it with some like #0000 grade steel wool.

Image may have been reduced in size. Click image to view fullscreen.


26. Here's a picture of the hole that the input shaft rides in, along with the original grease. Not sure what kind of grease that is, but as mentioned previously, some white lithium might do it, or I might try a light coat of moly wheel bearing grease.

Image may have been reduced in size. Click image to view fullscreen.


27/27a. Okay, last and least, my attempts at an "exploded view" of this assembly. One with captions, one without. These are large photos, you'll get a bit of zoom-in on them if you click to enlarge:


Image may have been reduced in size. Click image to view fullscreen.

Image may have been reduced in size. Click image to view fullscreen.


Reassembly - I put it back together in reverse order. Went together pretty well. I thought I'd have issues with the pin in the middle of the "cup" not wanting to line up with its bushing, but I temporarily put the needle drive bushing back on and used that to rock the cup around til it lined up. Went quick. Once I had the faceplate and needle drive bushing back on - I found that, as expected, the splines weren't right to allow the needle calibration to be the same as before. So I took the brass bushing off and repositioned it. Same thing. Grrr. Decided to give up and write this post instead. Cool


Hope that was helpful for someone out there!

-Andy
Back to top
View user's profile Send private message Send e-mail Gallery Classifieds Feedback
andk5591 Premium Member
Samba Member


Joined: August 29, 2005
Posts: 14040
Location: State College, PA
andk5591 is offline 

PostPosted: Thu Nov 06, 2008 5:55 pm    Post subject: Reply with quote

Holy Crap!!!!!!!!!!!!!!!!! Andy - you never cease to amaze me. As usual, great post
_________________
D-Dubya Manx clone - 63 Short pan,1914.
Rosie 65 bug - My mostly stock daily driver.
Woodie 69 VW woodie (Hot VWs 7/12).
"John's car" 64 VW woodie - The first ever
Maxine 61 Cal-look bug - Cindy's daily driver.
Max - 73 standard Beetle hearse project
66 bug project - Real patina & Suby conversion
There's more, but not keeping them...
Back to top
View user's profile Send private message Send e-mail AIM Address Gallery Classifieds Feedback
hpw
Samba Member


Joined: July 17, 2006
Posts: 3024
Location: memphis
hpw is offline 

PostPosted: Thu Nov 06, 2008 6:04 pm    Post subject: Reply with quote

Awesome Exclamation Exclamation Exclamation My vote for the best "How To" on thesamba
_________________
http://www.youtube.com/watch?v=3SLIzSCt_cg&list=FLIX26sGa8__1F1loczLPTtg&index=2
Back to top
View user's profile Send private message Send e-mail Gallery Classifieds Feedback
fluxcap
Samba Member


Joined: February 07, 2006
Posts: 1959
Location: Newnan GA
fluxcap is offline 

PostPosted: Thu Nov 06, 2008 7:09 pm    Post subject: Reply with quote

Awesome post Andy. Thanks for taking your time and doing this.
_________________
Eric - 1962 ragtop beetle and 1966 camper bus
visit our georgia forums at www.georgiadubs.com

"It's like, how much more black could this be, and the answer is none.......none more black."
Back to top
View user's profile Send private message Send e-mail Visit poster's website Gallery Classifieds Feedback
ninja90177
Samba Member


Joined: August 14, 2006
Posts: 640
Location: Las Vegas, NV
ninja90177 is offline 

PostPosted: Thu Nov 06, 2008 7:31 pm    Post subject: Reply with quote

Dude . . . That's awesome.

Thanks for taking the time to photograph the process. That's way too cool.

Kenney
_________________
Spun a rear drum? check this out
Back to top
View user's profile Send private message Classifieds Feedback
Hotrodvw
Samba Member


Joined: July 06, 2004
Posts: 6339
Location: Orygun
Hotrodvw is offline 

PostPosted: Thu Nov 06, 2008 8:21 pm    Post subject: Reply with quote

WOW!! Thanks! Now I know I don't want to tear it apart! Laughing Too much stuff!! But.......very good post. Applause
_________________
'67 Sunroof
Eric

78x94 with IDA's....oober fun

Horsepower is an addiction........Addictions cost
lots of money!

Hose & Fittings
Back to top
View user's profile Send private message AIM Address Gallery Classifieds Feedback
glutamodo Premium Member
The Android


Joined: July 13, 2004
Posts: 23263
Location: Douglas, WY
glutamodo is offline 

PostPosted: Thu Nov 06, 2008 11:48 pm    Post subject: Reply with quote

You're welcome everyone. At first I was only going to take a couple of pictures, but then I decided that while I had the camera set up, I might as well take it all the way apart. Actually, dismantling it while taking the photos wasn't that hard, (having a tripod helps a lot there) but it was the editing and captioning them that took the most time. Then I decided to make them larger photos with less compression than I usually do, so I put them in theSamba's Gallery, which is a lot more time consuming than how I do it when I use my own FTP webspace for photo hosting.

-Andy
Back to top
View user's profile Send private message Send e-mail Gallery Classifieds Feedback
andk5591 Premium Member
Samba Member


Joined: August 29, 2005
Posts: 14040
Location: State College, PA
andk5591 is offline 

PostPosted: Fri Nov 07, 2008 4:43 am    Post subject: Reply with quote

Quote:
WOW!! Thanks! Now I know I don't want to tear it apart! Too much stuff!! But.......very good post.


Andy is incredibly thorough and showed pretty much a compete teardown. You probably dont need to tear it down that far. Just remove the speedo from the "can". Clean up and regrease the odometer gear. Now take a look at Andy's 7th picture (speedo bearing or bushing). drop some 3-n-1 oil on the shaft to get it into the bushing - I also flipped the speedo face down to get some in toward the needle.

Put it back together and that will probably take care of your problem. (Make sure you clean the glass face real well - inside and out - first one I did I had fingerprints on the inside Embarassed )

You are looking at spending maybe 45 minutes on this if its the first time you take apart a speedo. Not rocket science.
_________________
D-Dubya Manx clone - 63 Short pan,1914.
Rosie 65 bug - My mostly stock daily driver.
Woodie 69 VW woodie (Hot VWs 7/12).
"John's car" 64 VW woodie - The first ever
Maxine 61 Cal-look bug - Cindy's daily driver.
Max - 73 standard Beetle hearse project
66 bug project - Real patina & Suby conversion
There's more, but not keeping them...
Back to top
View user's profile Send private message Send e-mail AIM Address Gallery Classifieds Feedback
64vdub
Samba Member


Joined: August 05, 2008
Posts: 612
Location: Sunny So. Cal
64vdub is offline 

PostPosted: Fri Nov 07, 2008 9:44 am    Post subject: Reply with quote

Thanks a lot all. Andy, what do I owe you? You're a sick man whos got the disease bad:) I think that maybe you should publish this! I can't thank you enough. I'll report back with my findings.
Back to top
View user's profile Send private message Gallery Classifieds Feedback
engineerscott
Samba Member


Joined: August 22, 2005
Posts: 451

engineerscott is offline 

PostPosted: Sun Nov 23, 2008 9:47 pm    Post subject: Reply with quote

This is a very good post on dissecting a VW speedometer/odometer. Andy has done some fine work in methodically documenting the disassembly with well commented photos. Seems like a candidate to be made a sticky. Anyone else agree?
Back to top
View user's profile Send private message Classifieds Feedback
KTPhil Premium Member
Samba Member


Joined: April 06, 2006
Posts: 23669
Location: Conejo Valley, CA
KTPhil is offline 

PostPosted: Sun Nov 23, 2008 10:07 pm    Post subject: Reply with quote

I smell another sticky...
Back to top
View user's profile Send private message Gallery Classifieds Feedback
Display posts from previous:   
Reply to topic    Forum Index -> Beetle - 1958-1967 All times are Mountain Standard Time/Pacific Daylight Savings Time
Page: 1, 2, 3, 4, 5, 6  Next
Page 1 of 6

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum

About | Help! | Advertise | Donate | Premium Membership | Privacy/Terms of Use | Contact Us | Site Map
Copyright © 1996-2016, Everett Barnes. All Rights Reserved.
Not affiliated with or sponsored by Volkswagen of America | Forum powered by phpBB