Hello! Log in or Register   |  Help  |  Donate  |  Buy Shirts New!  See all banner ads | Advertise on TheSamba.com  
TheSamba.com
 
1.6D alternator not charging - batt. light on dash not lighting.
Page: 1, 2  Next
Forum Index -> Vanagon Share: Facebook Twitter
Reply to topic
Print View
Quick sort: Show newest posts on top | Show oldest posts on top View previous topic :: View next topic  
Author Message
epowell
Samba Member


Joined: September 23, 2015
Posts: 4350
Location: Czech (mostly) Vancouver (sometimes)
epowell is offline 

PostPosted: Mon Sep 30, 2019 2:34 pm    Post subject: 1.6D alternator not charging - batt. light on dash not lighting. Reply with quote

The alternator is supposedly new...
Last year it was working and charging perfectly.
Now with a new battery in there, KEY-ON and the battery light at the dash is not lighting. Start engine and alt. is not charging.

What to do?

The alt. has a single 3-way connector out the back which has 2 large contact holes and 1 smaller hole. Starter battery charge 12.6V and the 2 large holes read 12.5V with KEY ON. The smaller hole read 12.2V.
The small blue wire from the batt. + terminal leading to the dash, reads 12.2V also.
The alt. house IS grounded.

Not sure what else to check and/or what to do... any ideas?

Thanks!
Ed
_________________
www.edwardpowell.com
Back to top
View user's profile Send private message Visit poster's website Gallery Classifieds Feedback
valvecovergasket
Samba Member


Joined: October 10, 2018
Posts: 711
Location: pnw
valvecovergasket is offline 

PostPosted: Mon Sep 30, 2019 3:18 pm    Post subject: Re: 1.6D alternator not charging - batt. light on dash not lighting. Reply with quote

its been a while, but from my mk1/mk2 days if the little alt lamp itself goes bad, you wont complete the excite circuit to start charging the alternator.

the light not coming on with the key suggests thats the case.

id start there
_________________
MegaSquirt resource - SpitfireEFI.com

'83 tdi westy - swap thread
Back to top
View user's profile Send private message Send e-mail Classifieds Feedback
MarkWard
Samba Member


Joined: February 09, 2005
Posts: 14097
Location: Palm Beach County, Florida
MarkWard is offline 

PostPosted: Mon Sep 30, 2019 4:06 pm    Post subject: Re: 1.6D alternator not charging - batt. light on dash not lighting. Reply with quote

Disconnect the blue wire from the alt. Key on it should have battery voltage. If you ground the blue wire with the key on, light in dash should light. Report back.
_________________
1982 Vanagon Camper with ALH TDI.
1990 Vanagon Camper Syncro.
In Car https://youtu.be/5hbfdUJR88Q
Back to top
View user's profile Send private message Gallery Classifieds Feedback
epowell
Samba Member


Joined: September 23, 2015
Posts: 4350
Location: Czech (mostly) Vancouver (sometimes)
epowell is offline 

PostPosted: Tue Oct 01, 2019 8:55 am    Post subject: Re: 1.6D alternator not charging - batt. light on dash not lighting. Reply with quote

MarkWard wrote:
Disconnect the blue wire from the alt. Key on it should have battery voltage. If you ground the blue wire with the key on, light in dash should light. Report back.


Light comes on with blue wire grounded...
Does this mean the problem is with the alt.?
Image may have been reduced in size. Click image to view fullscreen.

Image may have been reduced in size. Click image to view fullscreen.

Image may have been reduced in size. Click image to view fullscreen.

_________________
www.edwardpowell.com
Back to top
View user's profile Send private message Visit poster's website Gallery Classifieds Feedback
MarkWard
Samba Member


Joined: February 09, 2005
Posts: 14097
Location: Palm Beach County, Florida
MarkWard is offline 

PostPosted: Tue Oct 01, 2019 9:09 am    Post subject: Re: 1.6D alternator not charging - batt. light on dash not lighting. Reply with quote

I'm sure crazyvwvanman will answer this better, but a simple explanation is the alternator D+ terminal acts like a ground when the key is turned on. At the same time 12 volts is supplied from up front that "excites" the alternator into charging. At that point, the D+ terminal is no longer acting like a ground and 12 volts is fed back up the blue wire. Having 12 volts on both sides of the bulb, causes it to go out.

This explanation is to help you understand roughly what is going on, but is by no means complete or accurate.

Yes, I would suspect the voltage regulator or the alternator has an internal problem.
_________________
1982 Vanagon Camper with ALH TDI.
1990 Vanagon Camper Syncro.
In Car https://youtu.be/5hbfdUJR88Q
Back to top
View user's profile Send private message Gallery Classifieds Feedback
crazyvwvanman
Samba Member


Joined: January 28, 2008
Posts: 8854
Location: Orbiting San Diego
crazyvwvanman is offline 

PostPosted: Tue Oct 01, 2019 9:48 am    Post subject: Re: 1.6D alternator not charging - batt. light on dash not lighting. Reply with quote

Yes, try removing the regulator/brush assembly from the alternator. That is likely where the problem is. Check the brushes for length and surface, etc.

But as nasty as the alternator looks in the photo I'd think about a different one at some point.

Mark
Back to top
View user's profile Send private message Gallery Classifieds Feedback
epowell
Samba Member


Joined: September 23, 2015
Posts: 4350
Location: Czech (mostly) Vancouver (sometimes)
epowell is offline 

PostPosted: Tue Oct 01, 2019 11:07 am    Post subject: Re: 1.6D alternator not charging - batt. light on dash not lighting. Reply with quote

crazyvwvanman wrote:
Yes, try removing the regulator/brush assembly from the alternator. That is likely where the problem is. Check the brushes for length and surface, etc.

But as nasty as the alternator looks in the photo I'd think about a different one at some point.

Mark


The 3-way had a lot of oil in the spade connectors - which I cleaned up but didn't help anything...

now trying to get the volt.reg. off but it looks like a TORX head --- I don't seem to have such a screw driver here...

Image may have been reduced in size. Click image to view fullscreen.

_________________
www.edwardpowell.com
Back to top
View user's profile Send private message Visit poster's website Gallery Classifieds Feedback
epowell
Samba Member


Joined: September 23, 2015
Posts: 4350
Location: Czech (mostly) Vancouver (sometimes)
epowell is offline 

PostPosted: Mon Oct 14, 2019 2:17 am    Post subject: Re: 1.6D alternator not charging - batt. light on dash not lighting. Reply with quote

Thanks everyone for the help... I am now back in Czech and didn't have time to finish fixing this issue while in Vancouver... It will have to wait until next August.
_________________
www.edwardpowell.com
Back to top
View user's profile Send private message Visit poster's website Gallery Classifieds Feedback
epowell
Samba Member


Joined: September 23, 2015
Posts: 4350
Location: Czech (mostly) Vancouver (sometimes)
epowell is offline 

PostPosted: Fri Oct 16, 2020 10:41 am    Post subject: Re: 1.6D alternator not charging - batt. light on dash not lighting. Reply with quote

crazyvwvanman wrote:
Yes, try removing the regulator/brush assembly from the alternator. That is likely where the problem is. Check the brushes for length and surface, etc.



OK.... finally after a LONG time I am back in Vancouver, and I got some TORX bits, and will now remove the voltage regulator...

I hope it is a simply matter of unscrewing it and pulling it out... I will do that now and take some pics.

I have absolutely no idea what I am looking for or how to diagnose this thing...

Thanks
Ed
_________________
www.edwardpowell.com
Back to top
View user's profile Send private message Visit poster's website Gallery Classifieds Feedback
epowell
Samba Member


Joined: September 23, 2015
Posts: 4350
Location: Czech (mostly) Vancouver (sometimes)
epowell is offline 

PostPosted: Fri Oct 16, 2020 11:40 am    Post subject: Re: 1.6D alternator not charging - batt. light on dash not lighting. Reply with quote

So I managed to remove the VOLTAGE REGULATOR...
...and immediately noticed that the electrical contacts were corroded - so I cleaned them all up and in-installed the VR in the naive hope that that would fix it...
Went to the dash, KEY-ON, and still no Batt.light Sad

Any ideas?

Thanks
Ed
Image may have been reduced in size. Click image to view fullscreen.

Image may have been reduced in size. Click image to view fullscreen.

_________________
www.edwardpowell.com
Back to top
View user's profile Send private message Visit poster's website Gallery Classifieds Feedback
MarkWard
Samba Member


Joined: February 09, 2005
Posts: 14097
Location: Palm Beach County, Florida
MarkWard is offline 

PostPosted: Fri Oct 16, 2020 1:03 pm    Post subject: Re: 1.6D alternator not charging - batt. light on dash not lighting. Reply with quote

Iím going with my first test. If the light lights when you ground the blue wire I think itís time for another alternator. You could buy a new regulator and try that first. If no luck, you have a spare regulator for the future. Buy an alternator and install it. Or find a local auto electrical shop to rebuild yours using your new regulator. As you can tell, itís also the brush pack.

There is a remote possibility the blue wire is connected to the wrong terminal. It should be on the D+ terminal. Some diesel alternators have a W terminal for a tach reference.
_________________
1982 Vanagon Camper with ALH TDI.
1990 Vanagon Camper Syncro.
In Car https://youtu.be/5hbfdUJR88Q
Back to top
View user's profile Send private message Gallery Classifieds Feedback
epowell
Samba Member


Joined: September 23, 2015
Posts: 4350
Location: Czech (mostly) Vancouver (sometimes)
epowell is offline 

PostPosted: Fri Oct 16, 2020 1:24 pm    Post subject: Re: 1.6D alternator not charging - batt. light on dash not lighting. Reply with quote

MarkWard wrote:
Iím going with my first test. If the light lights when you ground the blue wire I think itís time for another alternator. You could buy a new regulator and try that first. If no luck, you have a spare regulator for the future. Buy an alternator and install it. Or find a local auto electrical shop to rebuild yours using your new regulator. As you can tell, itís also the brush pack.

There is a remote possibility the blue wire is connected to the wrong terminal. It should be on the D+ terminal. Some diesel alternators have a W terminal for a tach reference.


PS ---
OH, ONE MORE THING!!!!!!
I had reconnected the battery after the first V.REG check... then when going out to check the v.reg again, I noticed that the V.REG was pretty warm! Almost hot!!!
WTH? ....some kind of 'short'?

Here are some more pics showing that the brushes are not evenly worn.
Also the copper on the rotor is not totally clean..... however PO said the ALT is "new".

The ALT worked fine when I bought the van and the blue wire is part of a multiplug so I don't think the blue wire can be in the wrong hole.

I'm now guessing that the brushes are not good due to the un-even wear...

Is it not possible to DIY rebuild ALTs? ...or are they cheap enough not to bother?

Thanks
Image may have been reduced in size. Click image to view fullscreen.

Image may have been reduced in size. Click image to view fullscreen.

Image may have been reduced in size. Click image to view fullscreen.

Image may have been reduced in size. Click image to view fullscreen.

Image may have been reduced in size. Click image to view fullscreen.

Image may have been reduced in size. Click image to view fullscreen.

Image may have been reduced in size. Click image to view fullscreen.

Image may have been reduced in size. Click image to view fullscreen.

Image may have been reduced in size. Click image to view fullscreen.

_________________
www.edwardpowell.com


Last edited by epowell on Fri Oct 16, 2020 1:33 pm; edited 1 time in total
Back to top
View user's profile Send private message Visit poster's website Gallery Classifieds Feedback
epowell
Samba Member


Joined: September 23, 2015
Posts: 4350
Location: Czech (mostly) Vancouver (sometimes)
epowell is offline 

PostPosted: Fri Oct 16, 2020 1:31 pm    Post subject: Re: 1.6D alternator not charging - batt. light on dash not lighting. Reply with quote

PS ---
OH, ONE MORE THING!!!!!!
I had reconnected the battery after the first V.REG check... then when going out to check the v.reg again, I noticed that the V.REG was pretty warm! Almost hot!!!
WTH? ....some kind of 'short'?
_________________
www.edwardpowell.com
Back to top
View user's profile Send private message Visit poster's website Gallery Classifieds Feedback
MarkWard
Samba Member


Joined: February 09, 2005
Posts: 14097
Location: Palm Beach County, Florida
MarkWard is offline 

PostPosted: Fri Oct 16, 2020 1:37 pm    Post subject: Re: 1.6D alternator not charging - batt. light on dash not lighting. Reply with quote

Those molded plugs did fail internally. VW did away with them. The alternator has constant power, but at rest I would expect it to not be hot to touch.

You are welcome to take it apart. Not sure about repair parts. There are specific diodes and rectifiers. There are automotive electrical shops that rebuild alternators and starters. My hunch is a reman will be quicker. Cip1.ca or maybe Rock Auto if they have a
Distributor in Canada.
_________________
1982 Vanagon Camper with ALH TDI.
1990 Vanagon Camper Syncro.
In Car https://youtu.be/5hbfdUJR88Q
Back to top
View user's profile Send private message Gallery Classifieds Feedback
epowell
Samba Member


Joined: September 23, 2015
Posts: 4350
Location: Czech (mostly) Vancouver (sometimes)
epowell is offline 

PostPosted: Fri Oct 16, 2020 1:53 pm    Post subject: Re: 1.6D alternator not charging - batt. light on dash not lighting. Reply with quote

why would the v.reg. get hot?? This does NOT seem normal!
_________________
www.edwardpowell.com
Back to top
View user's profile Send private message Visit poster's website Gallery Classifieds Feedback
MarkWard
Samba Member


Joined: February 09, 2005
Posts: 14097
Location: Palm Beach County, Florida
MarkWard is offline 

PostPosted: Fri Oct 16, 2020 2:23 pm    Post subject: Re: 1.6D alternator not charging - batt. light on dash not lighting. Reply with quote

epowell wrote:
why would the v.reg. get hot?? This does NOT seem normal!


Internal short to ground. Do this at your own risk. I would remove the regulator and start the engine. Take a strip of emery cloth or 120 grit sand paper and dress the copper rings on the rotor. Be very careful. Donít loose a finger. I would also shine up the contact strip. I see a lot of rust and corrosion. Uneven brushes arenít the problem and they look like they have little wear. The harness looks like ass. Whatís the black tape hiding?
_________________
1982 Vanagon Camper with ALH TDI.
1990 Vanagon Camper Syncro.
In Car https://youtu.be/5hbfdUJR88Q
Back to top
View user's profile Send private message Gallery Classifieds Feedback
crazyvwvanman
Samba Member


Joined: January 28, 2008
Posts: 8854
Location: Orbiting San Diego
crazyvwvanman is offline 

PostPosted: Fri Oct 16, 2020 2:27 pm    Post subject: Re: 1.6D alternator not charging - batt. light on dash not lighting. Reply with quote

A new regulator assembly with brushes is about $15-20 delivered to me. Don't know about your side of the border.

A slightly higher output voltage one is about the same price.

Examples:

https://www.ebay.com/itm/Voltage-Regulator-3523710...Swp-RaawdR

https://www.ebay.com/itm/Voltage-Regulator-fits-19...Swnxxd4AnU

Mark
Back to top
View user's profile Send private message Gallery Classifieds Feedback
RawUmber
Samba Member


Joined: June 23, 2019
Posts: 103

RawUmber is offline 

PostPosted: Fri Oct 16, 2020 2:38 pm    Post subject: Re: 1.6D alternator not charging - batt. light on dash not lighting. Reply with quote

If I'm not mistaken, the regulator module should stay cool with key on, because it's not regulating. When the engine (and alternator) is running, it likely will warm up because it's regulating. If itís getting hot with just key on, I think you and Mark have isolated the problem.

FYI, you can buy new brushes, vreg, the whole module, not to mention a new alternator. I've read people on here suggest buying a lifetime warrantied alternator from a franchise that has stores where you tend to travel.

I like Mark's DIY abilities, but to be a little safer (yet much slower), maybe leave the engine off and free spin the alternator pulley (belt removed) by hand if you're going to go that route of sanding the copper. I agree though, the outer copper shaft ring surface looks less than perfect.
Back to top
View user's profile Send private message Gallery Classifieds Feedback
epowell
Samba Member


Joined: September 23, 2015
Posts: 4350
Location: Czech (mostly) Vancouver (sometimes)
epowell is offline 

PostPosted: Fri Oct 16, 2020 3:27 pm    Post subject: Re: 1.6D alternator not charging - batt. light on dash not lighting. Reply with quote

cleaned up the copper (fingers still intact) [actually I did it by proxy]
and cleaned everything else....
but still no BATT LIGHT

I'll go now to open up that black tape to see what lurks under it all...

V.reg, starts to get warm again just as soon as I connect the battery [no KEYON, but KEYOFF and battery hooked up] Shocked What's going on with THAT? Is it normal?
Image may have been reduced in size. Click image to view fullscreen.

_________________
www.edwardpowell.com
Back to top
View user's profile Send private message Visit poster's website Gallery Classifieds Feedback
RawUmber
Samba Member


Joined: June 23, 2019
Posts: 103

RawUmber is offline 

PostPosted: Fri Oct 16, 2020 3:42 pm    Post subject: Re: 1.6D alternator not charging - batt. light on dash not lighting. Reply with quote

epowell wrote:
V.reg, starts to get warm again just as soon as I connect the battery [no KEYON, but KEYOFF and battery hooked up] Shocked What's going on with THAT? Is it normal?

As MarkWard suggested, your module likely has a problem. If you want to chase it down, remove your module again and try ohm metering from the ground pin (the one that goes to the screw ring tab) to the other pins/brushes. You'll probably find one of the pins is measuring <1Kohm while the other is much higher (Mohm).

BTW, nice job cleaning up the shaft copper!
Back to top
View user's profile Send private message Gallery Classifieds Feedback
Display posts from previous:   
Reply to topic    Forum Index -> Vanagon All times are Mountain Standard Time/Pacific Daylight Savings Time
Page: 1, 2  Next
Page 1 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum

About | Help! | Advertise | Donate | Premium Membership | Privacy/Terms of Use | Contact Us | Site Map
Copyright © 1996-2020, Everett Barnes. All Rights Reserved.
Not affiliated with or sponsored by Volkswagen of America | Forum powered by phpBB