Hello! Log in or Register   |  Help  |  Donate  |  Buy Shirts  See all banner ads | Advertise on TheSamba.com  
TheSamba.com
 
28 PCI Accelerator pump not working
Forum Index -> Beetle - Oval-Window - 1953-57 Share: Facebook Twitter
Reply to topic
Print View
Quick sort: Show newest posts on top | Show oldest posts on top View previous topic :: View next topic  
Author Message
mabbo
Samba Member


Joined: October 13, 2004
Posts: 133
Location: united kingdom
mabbo is offline 

PostPosted: Wed Nov 13, 2019 3:05 pm    Post subject: 28 PCI Accelerator pump not working Reply with quote

Hi,

I have stripped down the original early 28PCI from my 55 as it was not squirting any fuel from the accelerator pump jet and I could not get the car to start. I cleaned and blew it all out with compressed air, put it back together and no fuel seems to be getting to the accelerator pump.

When the float bowl is full, Id have expected to see fuel when I removed the pump cover? Nothing at all was there when I tried:
Image may have been reduced in size. Click image to view fullscreen.


After doing some research I *think* the little brass pin visible in the picture needs to be removed to get access to a ball bearing that can get stuck when the carb hasnt been used in a long time, which causes the fuel not to get through to the pump? Is that right? I tried to get it out and struggled.

Any advice welcome.

Thanks
Back to top
View user's profile Send private message Send e-mail Gallery Classifieds Feedback
my59
Samba Member


Joined: August 13, 2003
Posts: 3174
Location: connecting the dots
my59 is offline 

PostPosted: Wed Nov 13, 2019 4:07 pm    Post subject: Re: 28 PCI Accelerator pump not working Reply with quote

Kroil and patience. It will come out. Good needle nose pliers, twist and pull. Gently does it.
Or take all the rubber and plastic bits off and leave it in a tub of carb cleaner for a few days and try again. Don't be in a hurry.
_________________
my59: Well son, my grandfather died before I got to drive it, so does that answer your question?
our79: sunroof bus w/camper interior and 2.0 FI
Other:'12 Jetta, '95 Benz E300D, 77 Benz 300D
Back to top
View user's profile Send private message Gallery Classifieds Feedback
Zwitterkafer
Samba Member


Joined: November 17, 2007
Posts: 639
Location: Lanark County, Ontario, Canada
Zwitterkafer is offline 

PostPosted: Wed Nov 13, 2019 7:12 pm    Post subject: Re: 28 PCI Accelerator pump not working Reply with quote

Yes, you are on the right track. The brass pin retains the smaller, lower check valve ball. The upper check valve ball is retained by the fitting tube. With everything cleaned out properly, you should be able to hear both balls rattling around as the carb is tilted this way and that.
_________________
"Criticism comes easier than Craftsmanship"
- Zeuxius, 400 BC
Back to top
View user's profile Send private message Gallery Classifieds Feedback
MotoMike
Samba Member


Joined: June 13, 2013
Posts: 117
Location: Durango, CO
MotoMike is offline 

PostPosted: Mon Dec 02, 2019 9:24 pm    Post subject: Re: 28 PCI Accelerator pump not working Reply with quote

I had a similar problem, and after staring at it for a long time, I drilled out the plug that is installed after machining. Let it soak in the carb cleaner overnight, machined a new plug and dabbed a little JB weld on it just for good measure. I was afraid I was going to wreck it trying to get the brass pin out. It freed up the check ball and worked good until I got a really nice carb from the guy in Utah, can't remember the name of his biz. By drilling out the plug, I could really get in there with the air and blow it out good. The passage has to make a couple of 90 degree turns and you can never get it cleaned out otherwise.
Back to top
View user's profile Send private message Gallery Classifieds Feedback
Display posts from previous:   
Reply to topic    Forum Index -> Beetle - Oval-Window - 1953-57 All times are Mountain Standard Time/Pacific Daylight Savings Time
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum

About | Help! | Advertise | Donate | Premium Membership | Privacy/Terms of Use | Contact Us | Site Map
Copyright © 1996-2020, Everett Barnes. All Rights Reserved.
Not affiliated with or sponsored by Volkswagen of America | Forum powered by phpBB